..
virtualbox solaris 10 / ffmpeg 설치하기
336x280(권장), 300x250(권장), 250x250, 200x200 크기의 광고 코드만 넣을 수 있습니다.

## virtualbox로 solaris10 설치 

참고

http://blog.naver.com/PostView.nhn?blogId=jhc3044&logNo=80104796222&parentCategoryNo=&categoryNo=4&viewDate=&isShowPopularPosts=false&from=postView

http://messier219.tistory.com/entry/VirtualBox%EC%97%90%EC%84%9C-Solaris-10-%EC%84%A4%EC%B9%98%EC%97%90%EC%84%9C-%EC%99%B8%EB%B6%80-SSH-%EC%A0%91%EC%86%8D%EA%B9%8C%EC%A7%80

# virtualbox에서 솔라리스 게스트 확장 설치 (공유폴더를 잡기위함)

1. CD-ROM에 VBoxGuestAdditions.iso 마운트

2. CD-ROM으로 디렉토리 변경
# cd /cdrom/vboxadditions_4.2.4_xxxxx

3. 설치 명령 실행
# pkgadd -G -d VBoxSolarisAdditions.pkg

0. Uninstall
# pkgrm SUNWvboxguest



출처: http://makebob.tistory.com/434 [大韓國人]


# 네트워크 설정

cat /etc/defaultrouter

10.0.2.2

cat /etc/resolv.conf

nameserver 59.187.192.80

nameserver 164.124.101.2

nameserver 168.126.63.1

cat /etc/hosts

127.0.0.1 localhost

10.0.2.16


# 솔라리스 설치 후 기본 설정

http://egloos.zum.com/gunsystems/v/6781303

---------------------------------------------------------------------------------------------

## ffmpeg 설치하기


솔라리스에서 아래의 패키지 설치

https://www.opencsw.org/package/ffmpeg/


http://ffmpeg.org/releases/?C=M;O=D

ffmpeg-3.1.9.tar.gz 파일 다운로드


*.tar.gz 압축풀기

gunzip *.tar.gz

tar -xvf *.tar


pkgadd -d ffmpeg-3.1.9


pkgadd -d http://get.opencsw.org/now
/opt/csw/bin/pkgutil -U
/opt/csw/bin/pkgutil -y -i ffmpeg 
/usr/sbin/pkgchk -L CSWffmpeg # list files


https://ffmpeg.org/


변환테스트

/opt/csw/bin/ffmpeg -i /mnt/sf_vm_share/input.wmv /mnt/sf_vm_share/output.mp4


---------------------------------------------------------------------------------------------

## shell script로 wmv -> mp4로 변환하기

#!/usr/bin/ksh

echo $SHELL


NOW_TIME=`date`

FFMPEG_BIN_DIR=/opt/csw/bin

FFMPEG_BASE_DIR=/mnt/sf_vm_share


FFMPEG_WORK_DIR=${FFMPEG_BASE_DIR}/ffmpeg_workdir

FFMPEG_END_DIR=${FFMPEG_BASE_DIR}/ffmpeg_enddir

FFMPEG_LOGS=${FFMPEG_BASE_DIR}/ffmpeg_logs


FFMPEG_ORG_FILES=${FFMPEG_BASE_DIR}/*.wmv

FFMPEG_ORG_WORK_FILES=${FFMPEG_WORK_DIR}/*.wmv

## 생성된지 10분이상된 파일만 추출하기


## Create directory

if [ ! -d ${FFMPEG_WORK_DIR} ]; then

mkdir ${FFMPEG_WORK_DIR}

fi


if [ ! -d ${FFMPEG_END_DIR} ]; then

mkdir ${FFMPEG_END_DIR}

fi


if [ ! -d ${FFMPEG_LOGS} ]; then

mkdir ${FFMPEG_LOGS}

fi


## Check the work file

if [ -f ${FFMPEG_ORG_WORK_FILES} ]; then

echo "[${NOW_TIME}] Working. Finish the batch."

exit

fi


## Moving work files 

if [ -f ${FFMPEG_ORG_FILES} ]; then

mv ${FFMPEG_ORG_FILES} ${FFMPEG_WORK_DIR}

else

echo "[${NOW_TIME}] No files to work with. Finish the batch."

exit

fi


## Converting Video Files

for file in ${FFMPEG_ORG_WORK_FILES}; do

if [ -f $file ]; then

filename=$(basename $file .wmv)

echo "[${NOW_TIME}] ${filename} Converting...."

${FFMPEG_BIN_DIR}/ffmpeg -y -i ${FFMPEG_WORK_DIR}/${filename}.wmv ${FFMPEG_BASE_DIR}/${filename}.mp4

else

echo "[${NOW_TIME}] No files to work with. Finish the batch."

exit

fi

done


## Moving the completed file

mv ${FFMPEG_ORG_WORK_FILES} ${FFMPEG_END_DIR}


#!/usr/bin/ksh

FFMPEG_BASE_DIR=/mnt/sf_vm_share

FFMPEG_LOGS=${FFMPEG_BASE_DIR}/ffmpeg_logs

${FFMPEG_BASE_DIR}/test.sh >> ${FFMPEG_LOGS}/ffmpeg_log_`date "+%Y%m%d"`.log 2>&1


'DEV > WEB WAS' 카테고리의 다른 글

webtob WEB-INF 접근 제한 처리  (0) 2017.08.25
jeus webadmin 패스워드  (0) 2014.02.05
Websphere version  (0) 2013.09.09
  Comments,     Trackbacks